HDU2602——Bone Collector

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9023    Accepted Submission(s): 3467


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

 

Sample Output
14
 
 
 
 
 
基本的01背包问题,状态方程f[v]=max{f[v],f[v-c[i]]}
 
代码:
View Code
#include <stdio.h>
#include <string.h>
#define N 1001

struct _bone
{
int value;
int volume;
}bone[N];

int f[N];

int max(int a, int b)
{
return a > b ? a : b;
}
int main()
{
int t, n, v;
int i, j, k;
scanf("%d", &t);
for(k=0;k<t;k++)
{
memset(f, 0, sizeof(f));
scanf("%d%d", &n, &v);
for(i=0;i<n;i++)
{
scanf("%d", &bone[i].value);
}
for(i=0;i<n;i++)
{
scanf("%d", &bone[i].volume);
}
for(i=0;i<n;i++)
{
for(j=v;j>=0;j--)
{
if(j >= bone[i].volume)
{
f[j] = max(f[j], f[j-bone[i].volume]+bone[i].value);
}
}
}
printf("%d\n", f[v]);
}
return 0;
}

posted @ 2011-12-08 15:10  1050768624  阅读(324)  评论(0编辑  收藏  举报