Pearls

                                             Pearls
                                Time Limit : 2000/1000ms (Java/Other) Memory Limit : 20000/10000K (Java/Other) 
Problem Description In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified by the price for one single pearl in that quality class. This price is unique for that quality class and the price is always higher then the price for a pearl in a lower quality class. Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl. Also The Royal Pearl is suffering from the slow-down of the global economy. Therefore the company needs to be more efficient. The CFO (chief financial officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the prices remain the same. For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro. The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program. Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one. Input The first line of the input contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000). The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending order. All numbers in the input are integers. Output For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.

Sample Input 2 2 100 1 100 2 3 1 10 1 11 100 12 Sample Output 330 1344

题意:买珍珠。无论你买哪一种价格的珍珠,必须买 你需要买的数量+10;低品质的珍珠可以用高品质的替代,所以你可以多买高品质的珍珠代替低品质的 以避免多买10个低品质的,已达到省钱的目的。求用最省钱的方式用的钱数。

思路:

首先需要证明一点,用高一等级的代替低一等级的必须是连续代替。例如 3 5, 90 7, 100 12 要想代替3个5价值的首先考虑 用7价值的代替,因为 3*7=21 (3+10)* 5 =65 显然比较合算,这样就不需要考虑用12价值的那个代替了,因为前面已经有了最优解,也就是说相互代替不会跳跃。

证明这一点后开始分析,用sum[i]表示前i中珠宝总数,对于第i等级珠宝,ans[i]表示他的最优解,那么ans[i]可能是(sum[i]+10) *p[i] 即前面所有的珠宝用i的价值去买,或者(sum[i]-sum[1] +10 )*p[i] + dp[1] 即从第二个开始前面的所有珠宝用i的价值去买,或者(sum[i]-sum[2] +10)*p[i] + dp[2] 即从第三个。。。。。。。。依次计算,其中最小的一个就是i的解

状态方程:  dp[j]=min(dp[j],(sum[j]-sum[k]+10)*p[j]+dp[k]);

源代码:

#include<iostream>
using namespace std;
int sum[1001],dp[1001];
int a[1001],p[1001];
int main()
{
    int i,j,k,n,c;
    cin>>n;
    for(i=1;i<=n;i++)
    {
        cin>>c;
        sum[0]=0;
        for(j=1;j<=c;j++)
        {
            cin>>a[j]>>p[j];
            sum[j]=sum[j-1]+a[j];
        }
        for(j=1;j<=c;j++)
        {
            dp[j]=(sum[j]+10)*p[j];
            for(k=1;k<j;k++)
            {
                dp[j]=min(dp[j],(sum[j]-sum[k]+10)*p[j]+dp[k]);
            }
        }
        cout<<dp[c]<<endl;
    }
    return 0;
}

 

 

posted on 2013-09-17 20:37  天梦Interact  阅读(288)  评论(0编辑  收藏  举报