Hashmat the Brave Warrior

 

今天因为一时没上去做题的网站,所以做了一点public比赛的题目,能上去时也没再去做,今天就先做点简单的吧。

A - Hashmat the Brave Warrior
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit
 
Status
Description
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.

Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.

Output
For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

Sample Input
10 12
10 14
100 200
Sample Output
2
4
100

  注意“vice versa”

代码:

#include<iostream>
using namespace std;
int main()
{
    long long n,m;
    while(cin>>n>>m)
    {
        if(n<m)
        cout<<m-n<<endl;
        else
            cout<<n-m<<endl;
    }
    return 0;
}

 

posted on 2013-08-28 22:16  天梦Interact  阅读(218)  评论(0编辑  收藏  举报