POJ 1163

 

http://poj.org/problem?id=1163

 

数塔  cxl说因为这个题喜欢上DP的 

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
题目让找出最大和,很多题都是顺着题意来从上往下找 可是不好做,  这个题又是倒过来想,从下往上找.就像那个求多个点到一个点的最短时间似的  倒过来就容易了  从终点走到多个点  先到哪个哪个就最短
代码:
#include<iostream>
#include<cstdio>
using namespace std;
int a[102][102];
int main()
{
int n,i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);

for(i=n-1;i>=1;i--)
for(j=1;j<=i;j++)
a[i][j]+=a[i+1][j]>a[i+1][j+1]?a[i+1][j]:a[i+1][j+1];

printf("%d\n",a[1][1]);
return 0;

}




posted @ 2011-12-10 00:27  快乐.  阅读(171)  评论(0编辑  收藏  举报