随笔- 181  文章- 2  评论- 0  阅读- 6809 

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.

Output
For each test case,output the answer on a single line.

Sample input
3
1 1
10 2
10000 72

Sample output
1
6
260

数学-欧拉函数

设X=a×m,N=b×m,则有gcd(a,b)=1,又a<=b故结果为phi(b),只需枚举合适的m即可

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int phi(int x)
{
	int res=x;
	for(int i=2;i*i<=x;++i)
	{
		if(x%i==0)
		res=res/i*(i-1);
		while(x%i==0) x/=i;
	}
	if(x>1) res=res/x*(x-1);
	return res;
}
void solve()
{
	int n,m;
	cin>>n>>m;
	int ans=0;
	for(int i=1;i*i<=n;++i)
	{
		if(n%i==0)
		{
			if(i>=m) ans+=phi(n/i);
			if(i*i!=n&&n>=(ll)i*m) ans+=phi(i);
		}
		//cout<<i<<' '<<ans<<"\n";
	}
	cout<<ans<<'\n';
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int T;
    cin>>T;
    while(T--)
    {
    	solve();
    }
    return 0;
}

 posted on   ruoye123456  阅读(63)  评论(0编辑  收藏  举报
相关博文:
阅读排行:
· 地球OL攻略 —— 某应届生求职总结
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 提示词工程——AI应用必不可少的技术
· .NET周刊【3月第1期 2025-03-02】
点击右上角即可分享
微信分享提示