hdu 1711 Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29131    Accepted Submission(s): 12255


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2 13
5 1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

 

Source
 

 

Recommend
 
kmp模板
#include <cstring>
#include <cstdio>
#define N 1000005

int t,n,m,a[N],b[N],Next[N];
void Get_next()
{
    int i=1,j=0;
    Next[i]=j;
    for(;i<=m;)
    {
        if(j==0||b[i]==b[j]) j++,i++,Next[i]=j;
        else j=Next[j];
    }
}
void kmp()
{
    Get_next();
    int i=1,j=1;
    for(;i<=n&&j<=m;)
    {
        if(j==0||b[j]==a[i]) i++,j++;
        else j=Next[j];
        if(j==m+1) {printf("%d\n",i-j+1);return;}
    }
    printf("-1\n");
}
int main()
{
    scanf("%d",&t);
    for(;t--;)
    {
        memset(Next,0,sizeof(Next));
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=1;i<=m;i++) scanf("%d",&b[i]);
        kmp();
    }
    return 0;
}

 

posted @ 2017-08-14 20:40  杀猪状元  阅读(145)  评论(0编辑  收藏  举报