POJ 2421 constructing roads

  

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

  Sample Output

  179

  Source

  • 有n个村庄,编号为1~n,我们需要建造道路使它们相互可以到达。
  • 一开始有一些道路已经建好了。 我们知道每两个村庄间建设道路的花费。
  • 求建设道路的最小花费。
  • N<=100

  这道题,我们只需要把原本已经连好的边把权值当成0,那么我们在进行最小生成树算法的时候,总会优先把这些边连上。点击传送

  kruskal 

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

struct node
{
    int x,y,dis;
}Edge[100001];
int fa[1001],N,i,a,tot,j,k;
bool cmp(node a,node b)
{
    return a.dis<b.dis;
}
int find_fa(int k)
{
    return fa[k]==k?k:find_fa(fa[k]);
}
int main()
{
    cin>>N;
    int a;
    for(i=1;i<=N;++i)
    {
        for(j=1;j<=N;++j)
        {
            cin>>a;
            if(a)
            {
                tot++;
                Edge[tot].x=i;
                Edge[tot].y=j;
                Edge[tot].dis=a;
            }
        }
    }
    int Q;
    cin>>Q;
    int b,c;
    for(i=1;i<=N;++i)
    fa[i]=i;
    int h=0;
    while(Q--)
    {
        cin>>b>>c;
        tot++;
        Edge[tot].x=b;
        Edge[tot].y=c;
        Edge[tot].dis=0;
    }
    sort(Edge+1,Edge+1+tot,cmp);
    int ans=0;
    for(i=1;i<=tot;++i)
    {
        int x,y;
        x=find_fa(Edge[i].x);
        y=find_fa(Edge[i].y);
        if(x!=y)
        {
            fa[y]=x;
            h++;
            ans+=Edge[i].dis;
            if(h==N-1)
            break;
        }
    }
    cout<<ans;
    return 0;
}

 

posted @ 2017-02-02 11:13  杀猪状元  阅读(187)  评论(0编辑  收藏  举报