poj 3169 Layout 差分约束模板题

Layout
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6415   Accepted: 3098

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. 

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.


建好了图,再SPFA即可!


#include "stdio.h"
#include "string.h"
#include "queue"
using namespace std;

#define N 1005
#define INF 0x3fffffff
/**
1. 如果要求最大值想办法把每个不等式变为标准x-y<=k的形式,然后建立一条从y到x权值为k的边,变得时候注意x-y<k =>x-y<=k-1

   如果要求最小值的话,变为x-y>=k的标准形式,然后建立一条从y到x的k边,求出最长路径即可

2.如果权值为正,用dijkstra,spfa,bellman都可以,如果为负不能用dijkstra,并且需要判断是否有负环,有的话就不存在
**/

int head[N],idx;
bool mark[N];
int dist[N],countt[N];

struct node
{
    int x,y;
    int next;
    int weight;
}edge[4*20*N];

void Init()
{
    idx = 0;
    memset(head,-1,sizeof(head));
}

void swap(int &a,int &b)
{
    int k = a;
    a = b;
    b = k;
}

void Add(int x,int y,int k)
{
    edge[idx].x = x;
    edge[idx].y = y;
    edge[idx].weight = k;
    edge[idx].next = head[x];
    head[x] = idx++;
}

bool SPFA(int start,int end)
{
    int i,x,y;
    memset(countt,0,sizeof(countt)); //统计每一个点加入队列的次数,判断是否有负环!
    memset(mark,false,sizeof(mark));
    for(i=start; i<=end; ++i)  dist[i] = INF;

    queue<int> q;
    q.push(start);
    countt[start]++;
    dist[start] = 0;

    mark[start] = true;
    while(!q.empty())
    {
        x = q.front();
        q.pop();
        for(i=head[x]; i!=-1; i=edge[i].next)
        {
            y = edge[i].y;
            if(dist[y]>dist[x]+edge[i].weight)
            {
                dist[y] = dist[x]+edge[i].weight;
                if(!mark[y])
                {
                    mark[y] = true;
                    q.push(y);
                    countt[y]++;
                    if(countt[y]>end) return false;
                }
            }
        }
        mark[x] = false;
    }
    return true;
}

int main()  /**求最大值,不等式化为x-y<=k的形式**/
{
    int n;
    int x,y,k;
    int ML,MD;
    while(scanf("%d %d %d",&n,&ML,&MD)!=EOF)
    {
        Init(); //初始化!
        while(ML--)
        {
            scanf("%d %d %d",&x,&y,&k);
            if(x>y) swap(x,y);
            Add(x,y,k); /**y-x<=k**/
        }
        while(MD--)
        {
            scanf("%d %d %d",&x,&y,&k);
            if(x>y) swap(x,y);
            Add(y,x,-k); /**y-x>=k  =>  x-y<=-k**/
        }
        bool flag = SPFA(1,n);
        if(!flag) printf("-1\n");
        else if(dist[n]==INF) printf("-2\n");
        else
            printf("%d\n",dist[n]);
    }
    return 0;
}











posted @ 2014-04-23 15:51  ruo_yu  阅读(259)  评论(0编辑  收藏  举报