www.cnblogs.com/ruiyqinrui

开源、架构、Linux C/C++/python AI BI 运维开发自动化运维。 春风桃李花 秋雨梧桐叶。“力尽不知热 但惜夏日长”。夏不惜,秋不获。@ruiY--秦瑞

python爬虫,C编程,嵌入式开发.hadoop大数据,桉树,onenebula云计算架构.linux运维及驱动开发.

  博客园  :: 首页  :: 新随笔  :: 联系 :: 订阅 订阅  :: 管理
  2912 随笔 :: 9 文章 :: 51 评论 :: 185万 阅读

demo控制脚本tel,150 5519 8367

Running Puppet on AIX

Puppet on AIX is… not officially supported, yet still useful (at least one site has it deployed in a production environment). It doesn’t work with the ruby packages that are available from bull at http://www.bullfreeware.com/, as they lack socket functionality, however it does when ruby is built from source with openssl support (at least on 5.2 and 5.3! On early versions, mileage may very etc). Currently, as at 0.22.4 there is still some big holes in functionality, specifically:

  • Mount doesn’t work. Thank you, IBM!
  • Cron jobs mysteriously fail with ‘crontab: cannot access’. Bug 2798
  • Service management via init works, however AIX by default uses something else for internal packages Feature 2864
  • Package support for installing/removing packages via NIM and local directory Bug 2805

Service Management

Most things on AIX are handled using the system resource controller (SRC).

lssrc -a list all services available and their state

startsrc -s sshd start a subsystem

stopsrc -s sshd stop a subsystem

refresh -s sshd refresh a subsystem (does not work on all subsystems, ssh for instance).

You can also pass -g instead of -s to start/stop a group of systems (such as NFS).

Services to be managed via the SRC can be defined with the mkssys command. The example adds the sshd subsystem and the ssh group to the SRC. In the example the binaries reside in /usr. The -a flag allows passing of arguments.

/usr/bin/mkssys -s sshd -p /usr/sbin/sshd -a ‘-D’ -u 0 -S -f 9 -n 15 -R -G ssh

The so generated subsystem sshd can be started with the above mentioned commands.

Package Maintenance

Packages are installed one or two ways. Locally using a local collection of .bff files (native BFF filesets) or remotely using Network Install Manager (NIM), which is similar to kickstart or jump start, plus there’s client management after the fact. NIM has the ability to remotely run simple scripts, reinstalling the OS, or making a system backup (mksysb).

NIM installation

The way that seems to be most common is to deploy packages with NIM. The client is configured to communicate with the NIM server using the niminit command. This can be run on the client or server. In most cases the entry on the server should be created first.

niminit -a name=HOSTNAME -a master=NIM_SERVER_FQDN -a connect=nimsh

Packages can then be installed using the nimclient command with the CUSTomize operation.

nimclient -o cust -a lpp_source=LPP_NAME -a filesets=“package1 package2 package3”

LPP_NAME is the name of the package repository on the server, you can discover the available sources with nimclient -l -t lpp_source.

Local Installation

If the packages are local (or on NFS) they can be installed with the installp command.

installp -acgXY -d /usr/sys/inst.images package1 package2 package3

-a means to apply packages (install)

-c (optional) commit packages to the system, cannot be rejected after this

-g (optional) process dependencies. If depends are not met, install fails.

-X automatically extend filesystems if needed.

-Y automatically accept License agreements.

-d dir use install source location

Before packages can be installed from a local repository, an index of metadata must be created. This is done with the inutoc command. This generates a .toc file in the directory that installp uses to know what packages are where. The filenames of the packages are irrelevant.

Handling mounts

Mounts are dynamically created/removed by commands, instead of modifying /etc/filesystems directly.

lsfs, list filesystems with their attributes

mkfs, creates a filesystem and adds it to /etc/filesystems

rmfs, removes a filesystem (and underlying block device unless the filesystem is not JFS or JFS2)

mknfsmnt, create an NFS mount in /etc/filesystems

rmnfsmnt, remove an NFS mount from /etc/filesystems

chfs, change the mountpoint, attributes, mounting groups, etc. of a filesystem (example: chfs -An /usr causes /usr to not mount on boot)

Mounts are handled exclusively via command line or smitty, using the above commands or importvg/exportvg.

Inittab

/etc/inittab is managed by {ch,ls,mk,rm}itab commands. Do not write changes to this as a text file.

pup-zlib-1.2.5-1.32.puppet.local.aix5.3.ppc.rpm (73.146 KB) Vincent Lin, 07/10/2012 10:41

pup-facter-1.6.3-1.puppet.local.aix5.3.noarch.rpm (63.178 KB) Vincent Lin, 07/10/2012 10:41

pup-openssl-1.0.0e-2.32.puppet.local.aix5.3.ppc.rpm (3.118 MB) Vincent Lin, 07/10/2012 10:41

pup-puppet-2.7.6-1.local.aix5.3.ppc.rpm (970.885 KB) Vincent Lin, 07/10/2012 10:41

pup-puppet-conf-0.1-1.local.aix5.3.noarch.rpm (1.618 KB) Vincent Lin, 07/10/2012 10:41

pup-ruby-1.8.7-p352.1.32.puppet.local.aix5.3.ppc.rpm (3.527 MB) Vincent Lin, 07/10/2012 10:41

posted on   秦瑞It行程实录  阅读(548)  评论(0编辑  收藏  举报
编辑推荐:
· 开发者必知的日志记录最佳实践
· SQL Server 2025 AI相关能力初探
· Linux系列:如何用 C#调用 C方法造成内存泄露
· AI与.NET技术实操系列(二):开始使用ML.NET
· 记一次.NET内存居高不下排查解决与启示
阅读排行:
· 开源Multi-agent AI智能体框架aevatar.ai,欢迎大家贡献代码
· Manus重磅发布:全球首款通用AI代理技术深度解析与实战指南
· 被坑几百块钱后,我竟然真的恢复了删除的微信聊天记录!
· 没有Manus邀请码?试试免邀请码的MGX或者开源的OpenManus吧
· 园子的第一款AI主题卫衣上架——"HELLO! HOW CAN I ASSIST YOU TODAY
历史上的今天:
2013-11-01 linux下创建具有root权限的账户
2013-11-01 字符集
www.cnblogs.com/ruiyqinrui
点击右上角即可分享
微信分享提示