hdu-Common Subsequence

http://acm.hdu.edu.cn/showproblem.php?pid=1159

 

Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0

 

 

最长公共子序列问题具有最优子结构性质


X = { x1 , ... , xm }
Y = { y1 , ... , yn }
及它们的最长子序列
Z = { z1 , ... , zk }

1、若 xm = yn , 则 zk = xm = yn,且Z[k-1] 是 X[m-1] 和 Y[n-1] 的最长公共子序列
2、若 xm != yn ,且 zk != xm , 则 Z 是 X[m-1] 和 Y 的最长公共子序列
3、若 xm != yn , 且 zk != yn , 则 Z 是 Y[n-1] 和 X 的最长公共子序列

由性质导出子问题的递归结构

当 i = 0 , j = 0 时 , c[i][j] = 0
当 i , j > 0 ; xi = yi 时 , c[i][j] = c[i-1][j-1] + 1
当 i , j > 0 ; xi != yi 时 , c[i][j] = max { c[i][j-1] , c[i-1][j] }

 

注意边界,两个串的下标都是从1开始的,因为递归时是以0为结束标志的~

dp[i][j]  表示的是 表示长度为i的字符串和长度为j的字符串的最大公共子串的长度


分析:

 

#include<iostream>
#include<string.h>
using namespace std;
char str1[1005];
char str2[1005];
int dp[1005][1005];
int main()
{
	while(scanf("%s %s",str1+1,str2+1)!=EOF)
	{	
	        memset(dp,0,sizeof(dp));//这一步就已经初始化边界了~ dp[0][j:1->len2]=0;
               int len1=strlen(str1+1),len2=strlen(str2+1);
	     for(int i=1;i<=len1;i++)
	     for(int j=1;j<=len2;j++)
	     {
     		if(str1[i]==str2[j])
     		dp[i][j]=dp[i-1][j-1]+1;
     		else
     		dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
     		
     	}
     	cout<<dp[len1][len2]<<endl; 
		
	}
	return 0;
}

 

另:

 

#include<iostream>
#include<cstring>
using namespace std;
int max(int a,int b)
{
	return a>b?a:b;
}
int main()
{
	int i,j,dp[500][500];
	string s1,s2;
	while(cin>>s1>>s2)
	{
		memset(dp,0,sizeof(dp));
		for(i=1;i<=s1.size();i++)
		{
			for(j=1;j<=s2.size();j++)
			{
				if(s1[i-1]==s2[j-1])dp[i][j]=dp[i-1][j-1]+1;
				else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
			}
		}
		cout<<dp[s1.size()][s2.size()]<<endl;
	}
	return 0;
}


 

 

 

posted on 2013-08-12 20:21  you Richer  阅读(129)  评论(0编辑  收藏  举报