ZOJ3714:Java Beans

There are N little kids sitting in a circle, each of them are carrying some java beans in their hand. Their teacher want to select M kids who seated in M consecutive seats and collect java beans from them.

The teacher knows the number of java beans each kids has, now she wants to know the maximum number of java beans she can get from M consecutively seated kids. Can you help her?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases.

For each test case, the first line contains two integers N (1 ≤ N ≤ 200) and M (1 ≤ M  N). Here N and M are defined in above description. The second line of each test case contains N integers Ci (1 ≤ Ci ≤ 1000) indicating number of java beans the ith kid have.

Output

For each test case, output the corresponding maximum java beans the teacher can collect.

Sample Input

2
5 2
7 3 1 3 9
6 6
13 28 12 10 20 75

Sample Output

16
158
 
题意:很简单,给出n,k,计算n个数中长度为k的最大和,而且其中没有负数,只需要注意这些数字组成的是一个环形
思路:数据很小,直接水过
 
#include <stdio.h>
#include <string.h>

int main()
{
    int t,n,k,i,j,a[405],sum,MAX;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            a[n+i] = a[i];
        }
        MAX = 0;
        for(i=1; i<=n; i++)
        {
            sum = 0;
            for(j = i; j<i+k; j++)
            {
                sum+=a[j];
            }
            if(sum>MAX)
            MAX = sum;
        }
        printf("%d\n",MAX);
    }
    return 0;
}

posted on 2013-07-28 20:34  you Richer  阅读(242)  评论(0编辑  收藏  举报