1087 Super Jumping! Jumping! Jumping! 【动态规划】

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

 


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

 

//a[i]  从第一个开始每次判断第i个数 
//a[j]从第一个数开始,每次判断第j个数直到第i个,dp[j] 之前加起来的总和,dp[i] 是之前总和大还是当前第i个数大 选大的那个
 
#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
#define MAX 1005
int a[MAX];
int dp[MAX]; 
int dpmax; 
int DP(int n){
	for(int i=1;i<=n;i++){
        dp[i] = a[i];  
        for(int j=1;j<i;j++){
            if(a[i] > a[j]){
                dp[i] = max(dp[j]+a[i],dp[i]);
            }
        }
        dpmax = max(dpmax,dp[i]);
    }
    return dpmax;
} 
int main(){
    int n;
    while(~scanf("%d",&n) && n != 0){
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        dpmax = a[0] = 0;
       	dpmax = DP(n);
        printf("%d\n",dpmax);
    }
    return 0;
}

 

posted @ 2017-03-27 22:54  Redscarf  阅读(233)  评论(0编辑  收藏  举报