hdu 1496,枚举

A - Equations
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Consider equations having the following form:

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input

The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output

For each test case, output a single line containing the number of the solutions.
 

Sample Input

1 2 3 -4 1 1 1 1
 

Sample Output

39088 0
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<vector>
#include<cstdlib>
#include<algorithm>

using namespace std;

#define LL long long
#define ULL unsigned long long
#define UINT unsigned int
#define MAX_INT 0x7fffffff
#define MAX_LL 0x7fffffffffffffff
#define MAX(X,Y) ((X) > (Y) ? (X) : (Y))
#define MIN(X,Y) ((X) < (Y) ? (X) : (Y))

int main(){

    int a,b,c,d;
     while(scanf(" %d %d %d %d",&a,&b,&c,&d)==4){
        if((a<0 && b<0 && c<0 && d<0) ||
           (a>0 && b>0 && c>0 && d>0)){
            printf("0\n");
            continue;
        }
        int i,j,k;
        LL ans=0;

        for(i=1; i<=100; i++)
            for(j=1; j<=100; j++)
                for(k=1; k<=100; k++){
                    int tmp=b*i*i + c*j*j + d*k*k;
                    if(MIN(tmp,a) <0 && MAX(tmp,a)>0){
                        int post=MAX(tmp,-tmp), posa=MAX(a,-a);
                        if(post%posa==0){
                            int x=(int)sqrt(0.5+post/posa);
                            if(x*x == post/posa  && x<=100) 
                                ans+=16;
                        }
                    }
                }
        printf("%lld\n",ans);
    }

    return 0;
}

 

posted @ 2013-11-07 18:31  Ramanujan  阅读(170)  评论(0编辑  收藏  举报