uva 558 Bellman-Ford template

  Wormholes 

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

 

  • Wormholes are one-way only.

     

  • The time it takes to travel through a wormhole is negligible.

     

  • A wormhole has two end points, each situated in a star system.

     

  • A star system may have more than one wormhole end point within its boundaries.

     

  • For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

     

  • Between any pair of star systems, there is at most one wormhole in either direction.

     

  • There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.

 


A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of course.

 


The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

 

Input 

The input file starts with a line containing the number of cases c to be analysed. Each case starts with a line with two numbers n and m . These indicate the number of star systems ( $1 \le n \le 1000$) and the number of wormholes ( $0 \le m \le 2000$) . The star systems are numbered from 0 (our solar system) through n-1 . For each wormhole a line containing three integer numbers x, y and t is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered x to the star system numbered y, thereby ending up t ( $-1000 \le t \le 1000$) years in the future.

 

Output 

The output consists of c lines, one line for each case, containing the word possible if it is indeed possible to go back in time indefinitely, or not possible if this is not possible with the given set of star systems and wormholes.

 

Sample Input 

 

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

 

Sample Output 

 

possible
not possible

 

 


Miguel A. Revilla
1998-03-10
 
判负环,模板搞定:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<vector>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>

using namespace std;

#define LL long long
#define UINT unsigned int
#define MAX_INT 0x7fffffff
#define cint const int
#define INF 100000000
#define MAXN 1111
#define MAXM 2999

struct edge{
    int u, v, w, nxt;
}e[MAXM];
int h[MAXN], cc, n, m;

void add(int u, int v, int w){
    e[cc]=(edge){u, v, w, h[u]};
    h[u]=cc++;
}

int d[MAXN], cnt[MAXN];
bool inq[MAXN];
bool bford(cint s){
    queue<int> q;
    fill_n(d, n, 0);             fill_n(cnt, n, 0);
    fill_n(inq, n, true);
    for(int i=0; i<n; i++) q.push(i);
    while(!q.empty()){
        int u = q.front();  q.pop();    inq[u]=false;
        for(int i=h[u]; i!=-1; i=e[i].nxt){
            int v = e[i].v, w = e[i].w;
            if(d[v] > d[u] + w){
                if(++cnt[v]>=n) return true;
                d[v] = d[u] + w;
                if(!inq[v]) q.push(v), inq[v]=true;
            }
        }
    }
    return false;
}

int main(){
//    freopen("C:\\Users\\Administrator\\Desktop\\in.txt","r",stdin);
    int kase;
    scanf(" %d", &kase);
    while(kase--){
        int i, u, v, w;
        scanf(" %d %d", &n, &m);
        fill_n(h, n, -1);   cc=0;
        for(i=0; i<m; i++){
            scanf(" %d %d %d", &u, &v, &w);
            add(u, v, w);
        }
        if(bford(0)) printf("possible\n");
        else printf("not possible\n");
    }
    return 0;
}

 

posted @ 2013-10-18 01:33  Ramanujan  阅读(189)  评论(0编辑  收藏  举报