uva 1349 带权最大匹配 拆点

A big city wants to improve its bus transportation system. One of the improvement is to add scenic routes which go es through attractive places. Your task is to construct a bus-route-plan for sight-seeing buses in a city.

You are given a set of scenic lo cations. For each of these given lo cations, there should be only one bus route that passes this lo cation, and that bus route should pass this lo cation exactly once. The number of bus routes is unlimited. However, each route should contain at least two scenic lo cations.

From location i to location j , there may or may not be a connecting street. If there is a street from location i to location j , then we say j is an out-neighbor of i . The length of the street from i to j is d (i, j) . The streets might be one way. So it may happen that there is a street from i to j , but no street from j to i . In case there is a street from i to j and also a street from j to i , the lengths d (i, j) and d (j, i) might be different. The route of each bus must follow the connecting streets and must be a cycle. For example, the route of Bus A might be from location 1 to location 2, from location 2 to location 3, and then from location 3 to location 1. The route of Bus B might be from location 4 to location 5, then from location 5 to location 4. The length of a bus route is the sum of the lengths of the streets in this bus route. The total length of the bus-route-plan is the sum of the lengths of all the bus routes used in the plan. A bus-route-plan is optimal if it has the minimum total length. You are required to compute the total length of an optimal bus-route-plan.

 

Input 

The input file consists of a number of test cases. The first line of each test case is a positive integer n , which is the number of locations. These n locations are denoted by positive integers 1, 2,..., n . The next n lines are information about connecting streets between these lo cations. The i -th line of these n lines consists of an even number of positive integers and a 0 at the end. The first integer is a lo cation j which is an out-neighbor of location i , and the second integer is d (i, j) . The third integer is another location j' which is an out-neighbor of i , and the fourth integer is d (i, j') , and so on. In general, the (2k - 1) th integer is a location t which is an out-neighbor of location i , and the 2k th integer is d (i, t) .

The next case starts immediately after these n lines. A line consisting of a single `0' indicates the end of the input file.

Each test case has at most 99 locations. The length of each street is a positive integer less than 100.

 

Output 

The output contains one line for each test case. If the required bus-route-plan exists, then the output is a positive number, which is the total length of an optimal bus-route-plan. Otherwise, the output is a letter `N'.

 

Sample Input 

 

3 
2 2 3 1 0 
1 1 3 2 0 
1 3 2 7 0  
8 
2 3 3 1 0 
3 3 1 1 4 4 0
1 2 2 7 0 
5 4 6 7 0 
4 4 3 9 0 
7 4 8 5 0 
6 2 5 8 8 1 0
6 6 7 2 0
3 
2 1 0 
3 1 0 
2 1 0
0

 

Sample Output 

 

7 
25 
N


参考:http://blog.csdn.net/jayye1994/article/details/10050695

为什么拆点求完美匹配可以判断是否形成环呢?
理解:画图:1.不含环;2.含环,但环外还有点。
如何保证最小? ---相反数

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<vector>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<map>

using namespace std;

#define LL long long
#define ULL unsigned long long
#define UINT unsigned int
#define MAX_INT 0x7fffffff
#define cint const int
#define MAX(X,Y) ((X) > (Y) ? (X) : (Y))
#define MIN(X,Y) ((X) < (Y) ? (X) : (Y))

#define MAXN 110
#define MAXM 10000
#define INF 100000000

int w[MAXN][MAXN], n, lft[MAXN];
int lx[MAXN], ly[MAXN], slack[MAXN];
bool s[MAXN], t[MAXN];

bool match(int u){
    s[u]=true;
    for(int v=1; v<=n; v++){
        if(t[v]) continue;
        int d=lx[u]+ly[v]-w[u][v];
        if(!d){
            t[v]=true;
            if(-1==lft[v] || match(lft[v])){
                lft[v]=u;
                return true;
            }
        }
        else slack[v]=MIN(slack[v], d);
    }
    return false;
}

void solve(){
    int i, j;
    fill_n(ly+1, n, 0);
    fill_n(lft+1, n, -1);
    for(i=1; i<=n; i++)
        for(j=1, lx[i]=-INF; j<=n; j++)
            lx[i]=MAX(lx[i], w[i][j]);
    for(i=1; i<=n; i++){
        fill_n(slack+1, n, INF);
        while(true){
            fill_n(s+1, n, 0);
            fill_n(t+1, n, 0);
            if(match(i)) break;
            int d=INF;
            for(j=1; j<=n; j++) if(!t[j])
                d=MIN(d, slack[j]);
            for(j=1; j<=n; j++){
                if(s[j]) lx[j]-=d;
                if(t[j]) ly[j]+=d;
            }
        }
    }

    int ans=0;
    for(i=1; i<=n; i++){
        if(w[lft[i]][i]==-INF) break;
        else ans+=w[lft[i]][i];
    }
    if(i<=n) printf("N\n");
    else printf("%d\n", -ans);
}

int main(){
//    freopen("C:\\Users\\Administrator\\Desktop\\in.txt","r",stdin);
    while(scanf(" %d", &n)==1 && n){
        int u, v, tw;
        for(u=1; u<=n; u++)
            fill(w[u]+1, w[u]+1+n, -INF);
        for(u=1; u<=n; u++){
            while(scanf(" %d", &v)==1 && v){
                scanf(" %d", &tw);
                w[u][v]=MAX(-tw, w[u][v]);
            }
        }
        solve();
    }
    return 0;
}

 



posted @ 2013-10-10 22:26  Ramanujan  阅读(261)  评论(0编辑  收藏  举报