(记录前面算过的后面仍然会用的数减小复杂度)A - AC Me

Description

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears. 

It's really easy, isn't it? So come on and AC ME. 
 

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file. 

Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file. 
 

Output

For each article, you have to tell how many times each letter appears. The output format is like "X:N". 

Output a blank line after each test case. More details in sample output. 
 

Sample Input

hello, this is my first acm contest! work hard for hdu acm.
 

Sample Output

a:1 b:0 c:2 d:0 e:2 f:1 g:0 h:2 i:3 j:0 k:0 l:2 m:2 n:1 o:2 p:0 q:0 r:1 s:4 t:4 u:0 v:0 w:0 x:0 y:1 z:0 a:2 b:0 c:1 d:2 e:0 f:1 g:0 h:2 i:0 j:0 k:1 l:0 m:1 n:0 o:2 p:0 q:0 r:3 s:0 t:0 u:1 v:0 w:1 x:0 y:0 z:0
 
 
问题:录入一句话,输出这句话中出现的每个小写英文字母的个数
分析:这题看起来很简单,用gets录入字符串,遍历每组字符串,记录相应字母出现次数的变量加加就行了,然而刚开始交的代码老超时,
   后来发现for(int i = 0; i < strlen(s); i++)中,每进行一次for循环就要调用一次strlen函数,从而增加时间,
     改为len = strlen(s),for(int i = 0; i < len; i++)就过了
 
#include <stdio.h>
#include <string.h>
#include <malloc.h>
#define M 100000+10
int main()
{
    char s[M];
    int cnt[125], len;
    while(gets(s))
    {
        len = strlen(s);
        for(int i = 0; i < 125; i++)
            cnt[i] = 0;
        for(int i = 0; i < len; i++)
        {
            for(int j = 97; j < 123; j++)
            {
                if(s[i] == j)
                    cnt[j]++;
            }
        }
        for(int i = 97; i < 123; i++)
            printf("%c:%d\n", i, cnt[i]);
        printf("\n");
    }
    return 0;
}

 

posted on 2015-10-17 20:32  张明明_1  阅读(222)  评论(0编辑  收藏  举报

导航