POJ 2342 Label:树形dp

Anniversary party

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6955   Accepted: 4003

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

代码

#include<iostream>
#include<cstdio> 
#include<cstring>
#include<algorithm>
#define INF 1<<30
using namespace std;

int father[6003],dp[6003][2],visit[6003],N,l,k,root;

void dfs(int node){
//    visit[node]=1;
    for(int i=1;i<=N;i++){
        if(/*visit[i]==0&&*/father[i]==node){
            dfs(i);
            dp[node][1]+=dp[i][0];
            dp[node][0]+=max(dp[i][1],dp[i][0]);
        }
    }
}

int main(){
//    freopen("01.txt","r",stdin);
    scanf("%d",&N);
    for(int i=1;i<=N;i++){
        scanf("%d",&dp[i][1]);//去的情况 
    }
    while(scanf("%d%d",&l,&k)==2&&l+k>0){
        father[l]=k;
        root=k;
    }
    dfs(root);
    printf("%d\n",max(dp[root][0],dp[root][1]));
    return 0;
}

我不会说这是TYVJ P1052 没有上司的舞会(数据都一样...)

//题意:有n个人,接下来n行是n个人的价值,再接下来n行给出l,k说的是l的上司是k,这里注意l与k是不能同时出现的
//思路:用dp数据来记录价值,开数组用下标记录去或者不去

则状态转移方程为:

DP[i][1] += DP[j][0],

DP[i][0] += max{DP[j][0],DP[j][1]};其中j为i的孩子节点。

这样,从根节点r进行dfs,最后结果为max{DP[r][0],DP[r][1]

posted @ 2016-08-19 11:17  Radiumlrb  阅读(156)  评论(0编辑  收藏  举报