数字三角形poj1163
The Triangle
Description
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
Sample Output
30
#include<stdio.h>
int d[110][110];
int n;
int sum[110][110];
main()
{
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&d[i][j]);
for(j=1;j<=n;j++)
sum[n][j]=d[n][j];
for(i=n;i>1;i--)
for(j=1;j<i;j++)
{
if(sum[i][j]>sum[i][j+1]) sum[i-1][j]=sum[i][j]+d[i-1][j];
else sum[i-1][j]=sum[i][j+1]+d[i-1][j];
}
printf("%d",sum[1][1]);
}
int d[110][110];
int n;
int sum[110][110];
main()
{
int i,j;
scanf("%d",&n);
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&d[i][j]);
for(j=1;j<=n;j++)
sum[n][j]=d[n][j];
for(i=n;i>1;i--)
for(j=1;j<i;j++)
{
if(sum[i][j]>sum[i][j+1]) sum[i-1][j]=sum[i][j]+d[i-1][j];
else sum[i-1][j]=sum[i][j+1]+d[i-1][j];
}
printf("%d",sum[1][1]);
}