DFS深搜poj1979
深搜,从一点向各处搜找到所有能走的地方。
Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 12004 | Accepted: 6097 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
#include<iostream>
using namespace std;
char map[22][22];
int sum,l,h;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
bool border(int x,int y)
{
if(x<0||x>=h||y<0||y>=l) return 0;
return 1;
}
void search(int x,int y)
{
int i;
int xx,yy;
sum++;
map[x][y]='#';
for(i=0;i<4;i++)
{
xx=x+dir[i][0];
yy=y+dir[i][1];
if(border(xx,yy)&&map[xx][yy]=='.')
search(xx,yy);
}
}
int main()
{
int i,j;
int x0,y0;
while(cin>>l>>h)
{
sum=0;
if(l==0&&h==0)break;
for(i=0;i<h;i++)
{
for(j=0;j<l;j++)
{
cin>>map[i][j];
if(map[i][j]=='@')
{
x0=i;
y0=j;
}
}
}
search(x0,y0);
cout<<sum<<endl;
}
return 0;
}