kmp hdu 2594

Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19249    Accepted Submission(s): 6521


http://acm.hdu.edu.cn/showproblem.php?pid=2594

Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

 

Sample Input
clinton homer riemann marjorie
 

 

Sample Output
0 rie 3
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
char str1[maxn],str2[maxn];
int Next[maxn];
int len1,len2;
void getnext(){
    int k=-1;
    int j=0;
    Next[0]=-1;
    while(j<len1){
        if(k==-1||str1[j]==str1[k]){
            k++;
            j++;
            Next[j]=k;
        }else{
            k=Next[k];
        }
    }
    return;
}
int main(){
    while(scanf("%s%s",str1,str2)!=EOF){
        len1=strlen(str1);
        len2=strlen(str2);
        int temp;
        temp=min(len1,len2);
        for(int i=len1;i<len1+len2;i++){
            str1[i]=str2[i-len1];
        }
        str1[len1+len2]='\0';
        len1+=len2;
        //printf("%s\n",str1);
        getnext();
        int ans=Next[len1];
        if(ans>temp){
            ans=temp;
        }
        for(int i=0;i<ans;i++){
             printf("%c",str1[i]);
        }
        if(ans!=0){
            printf(" %d\n",ans);
        }else{
            printf("0\n");
        }
         
    }
    return 0;
} 

 

posted @ 2019-09-26 09:37  jhjdsdsgd  阅读(107)  评论(0编辑  收藏  举报