kmp hdu 1711

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 53712    Accepted Submission(s): 21540


http://acm.hdu.edu.cn/showproblem.php?pid=1711

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

 

Sample Output
6 -1
#include<cstdio>
#include<cstring>
const int maxn=1e6+4;
int next[10000+5];
int a[maxn],b[10000+5];
int t,n,m;
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        int i;
        for(i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(i=0;i<m;i++){
            scanf("%d",&b[i]);
        }
        int j=0,k=-1;
        next[0]=-1;
        while(j<m){
            if(k==-1||b[k]==b[j]){
                ++k;
                ++j;
                if(b[j]!=b[k]){
                    next[j]=k;
                }else{
                    next[j]=next[k];
                }
            }else{
                k=next[k];
            }
        }
        i=0,j=0;
        int flag=0;
        while(i<n&&j<m){
            if(j==-1||a[i]==b[j]){
                i++;
                j++;
            }else{
                j=next[j];
            }
        //    printf("%d %d\n",i,j);
            if(j==m-1&&a[i]==b[j]){
            //    printf("%d %d\n",i,j);
                printf("%d\n",i-j+1);
                flag=1;
                break;
            }
        }
        if(flag==0){
            printf("-1\n");
        }
    }
    return 0;
}

 

posted @ 2019-09-11 15:58  jhjdsdsgd  阅读(88)  评论(0编辑  收藏  举报