poj 2828

http://poj.org/problem?id=2828

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i(1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

 

题解:

    一个数,如果后来插了N个数,它就要向后移动N位;

   倒着输入,后来插入的数就会先输入,就可以确定向后移动几位;

   用树记录空位子数,就可以确定在那插了;

   因为如果倒着输入,非空位子都是后来插的,所以 i 数的位置为对应第 i 个空位子;

 

 

#include<cstdio>
using namespace std;

const int maxn=200000+2;

struct node
{
    int p,va;
};
node arr[maxn];

struct segtree
{
    int l,r,num;
};
segtree tree[maxn*4+2];

int N;
int sum[maxn];

void build(int n,int l,int r)//建成记录空位子数的数;
{
    tree[n].l=l;
    tree[n].r=r;
    if(tree[n].l==tree[n].r)
    {
        tree[n].num=1;
        return;
    }
    int mid=(tree[n].l+tree[n].r)/2;
    build(n*2,l,mid);
    build(n*2+1,mid+1,r);
    tree[n].num=tree[n*2].num+tree[n*2+1].num;
}

void updata(int n,int l,int r,int p,int va)
{
    if(l==r)
    {
        sum[l]=va;把数的代号存起来;
        tree[n].num=0;//输入一个数则对应位置空位子数就为0;
        return;
    }
    int mid=(tree[n].l+tree[n].r)/2;//向下递归搜索;
    if(p>tree[n*2].num)
    {
        p=p-tree[n*2].num;
        updata(n*2+1,mid+1,r,p,va);
    }
    else if(p<=tree[n*2].num)
    {
        updata(n*2,l,mid,p,va);
    }
    tree[n].num=tree[n*2].num+tree[n*2+1].num;
}

int main()
{
    while(~scanf("%d",&N))
    {
        build(1,1,N);
        for(int i=1;i<=N;i++)
        {
             scanf("%d%d",&arr[i].p,&arr[i].va);
        }
        for(int i=N;i>0;i--)
        {
            updata(1,1,N,arr[i].p+1,arr[i].va);
        }
        printf("%d",sum[1]);
        for(int i=2;i<=N;i++)
        {
            printf(" %d",sum[i]);
        }
        printf("\n");
    }
    return 0;
} 

 

#include<cstdio>
using namespace std;
const int maxn=200000+5;
struct {
    int p,va;
}a[maxn];//用于存每次输入的值;
struct{
    int l,r,num;
}tree[maxn*3+2];//用于存树;
int n; 
int sum[maxn];//存每个枝梢的值,也就是每个位置的值; 
void build(int s,int l,int r){
    tree[s].l=l;
    tree[s].r=r;
    if(l==r){
        tree[s].num=1;//每个位置的空位数为一; 
        return;
    }else{
        int mid=(l+r)/2;
        build(s*2,l,mid);
        build(s*2+1,mid+1,r);
        tree[s].num=tree[s*2].num+tree[s*2+1].num;//根节点记录子节点的总的空位数; 
    }
}
void updata(int s,int l,int r,int p,int va){
    if(l==r){
        sum[l]=va;
        tree[s].num=0;//在这里放了数,则这里就没有空位; 
        return; 
    }else{
        int mid=(l+r)/2;
        if(p<=tree[s*2].num){//根据空位置数查找; 
            updata(s*2,l,mid,p,va);
        }else if(p>tree[s*2].num){
            updata(s*2+1,mid+1,r,p-tree[s*2].num,va);
        }
        tree[s].num=tree[s*2].num+tree[s*2+1].num;//查找完后更新; 
    }
}
int main(){
    while(scanf("%d",&n)!=EOF){
        build(1,1,n);
        for(int i=1;i<=n;i++){
            scanf("%d%d",&a[i].p,&a[i].va);
        }
        for(int i=n;i>=1;i--){
            updata(1,1,n,a[i].p+1,a[i].va);
        }
        printf("%d",sum[1]);
        for(int i=2;i<=n;i++){
            printf(" %d",sum[i]);
        }
        printf("\n");
    } 
    return 0;
} 

 

posted @ 2019-03-13 19:49  jhjdsdsgd  阅读(91)  评论(0编辑  收藏  举报