本题要求编写程序,对输入的一个整数,从高位开始逐位分割并输出它的各位数字。
输入格式:
输入在一行中给出一个长整型范围内的非负整数。
输出格式:
从高位开始逐位输出该整数的各位数字,每个数字后面有一个空格。
输入样例:
123456
结尾无空行
输出样例:
1 2 3 4 5 6
#include<stdio.h>
int main()
{
int n,count=1,w;
scanf("%d",&n);
w=n;
while(w>9)//少取count一个零
{
w=w/10;
count=count*10;
}
while(count>0)
{
printf("%d ",n/count);
n=n%count;//留下除第一位以外的数;
count=count/10;
}
return 0;
}
看过了大佬的代码的。