浙大1018 Be carefull

Be carefull
Time Limit:1000MS  Memory Limit:32768K


Description:
“Be carefull about the precision!”When Tyr doing his mathemetic homework,teacher Mr.Qian always giving this warning to him.Now,Tyr has finished his mathemetic homework,and here is your task to check whether Tyr’s answer is correct or not.

Input:
The input consist of several cases.The first line gives the case number N, the next part has N cases.Each case is consist of two number R and I.R is a real number; I is an integer number.
Output:
For each case please give your check.If R rounds to I,then print “Correct” in a single line, or,print “Not Correct”.For more detail,please look at the samples.
Sample Input:
5
1.20 1
0.5 1
9.9 10
2.9 2
3.4999 3Sample Output:
Correct
Correct
Correct
Not Correct
Correct

解答:(实质就是一个四舍五入的题)
#include <iostream>
#include <string>
using namespace std;
int main()
{
 int a,t,T,tmp;
 double s;
 scanf("%d",&T);
 while(T--)
 {
  scanf("%lf%d",&s,&a);
  s=s*10;
  tmp=s;
  t=tmp%10;
  tmp/=10;
  if(t>4) tmp+=1;
  if(tmp==a) printf("Correct\n");
  else printf("Not Correct\n");
 }
 return 0;
}

posted on 2010-03-21 17:56  蓝牙  阅读(318)  评论(0编辑  收藏  举报