pat甲级 1107. Social Clusters (30)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A "social cluster" is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (<=1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

Ki: hi[1] hi[2] ... hi[Ki]

where Ki (>0) is the number of hobbies, and hi[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

分析:并查集的简单应用:解决关键是将人属于同一集合的合并起来,本题应该通过相同的爱好合并起来;
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

vector<int> father(1005), num(1005);
int cnt;//记录集合数

//sort()从大到小排序比较函数
bool cmp(int a, int b){
    return a > b;
}

//初始化,每个人属于不同集合
void init(int n){
    for(int i = 1; i <= n; i++){
        father[i] = i;
    }
}

int GetParent(int x){
    if(x == father[x])
        return x;
    father[x] = GetParent(father[x]);//路径压缩
    return father[x];
}


void merge(int x, int y){
    int fx = GetParent(x);
    int fy = GetParent(y);
    if(fx != fy){
        cnt--;//不属于同一集合,合并之后集合数减一
        father[fy] = fx;
    }
}

int main(){
    int n, k, h, i;
    int hobby[1005] = {0};
    scanf("%d", &n);

    //调用初始化函数
    init(n);

    cnt = n;//初始化集合数为n
    
    //处理输入数据,合并集合
    for(i = 1; i <= n; i++) {
        scanf("%d:", &k);
        for(int j = 0; j < k; j++) {
            scanf("%d", &h);
            if(hobby[h] == 0)
                hobby[h] = i;
            merge(hobby[h], i);
        }
    }
    for(i = 1; i <= n; i++)
        //这里一定要注意,要找到i所属集合的根节点,num加一,num[father[i]]++是有问题的,因为
        //这棵树深度不一定是2.。。即father[i]不一定是i所属集合的根节点
        num[GetParent(i)]++;

    printf("%d\n", cnt);

    sort(num.begin(), num.end(), cmp);

    printf("%d", num[0]);
    for(i = 1; i < cnt ; i++)
        printf(" %d", num[i]);
    return 0;
}

 

 
posted @ 2017-02-23 08:53  琴影  阅读(583)  评论(0编辑  收藏  举报