bzoj 2763
Description
Alice和Bob现在要乘飞机旅行,他们选择了一家相对便宜的航空公司。该航空公司一共在n个城市设有业务,设这些城市分别标记为0到n-1,一共有m种航线,每种航线连接两个城市,并且航线有一定的价格。Alice和Bob现在要从一个城市沿着航线到达另一个城市,途中可以进行转机。航空公司对他们这次旅行也推出优惠,他们可以免费在最多k种航线上搭乘飞机。那么Alice和Bob这次出行最少花费多少?
Input
数据的第一行有三个整数,n,m,k,分别表示城市数,航线数和免费乘坐次数。
第二行有两个整数,s,t,分别表示他们出行的起点城市编号和终点城市编号。(0<=s,t<n)
接下来有m行,每行三个整数,a,b,c,表示存在一种航线,能从城市a到达城市b,或从城市b到达城市a,价格为c。(0<=a,b<n,a与b不相等,0<=c<=1000)
Output
只有一行,包含一个整数,为最少花费。
Sample Input
5 6 1
0 4
0 1 5
1 2 5
2 3 5
3 4 5
2 3 3
0 2 100
Sample Output
8
HINT
对于30%的数据,2<=n<=50,1<=m<=300,k=0;
对于50%的数据,2<=n<=600,1<=m<=6000,0<=k<=1;
对于100%的数据,2<=n<=10000,1<=m<=50000,0<=k<=10.
做法:
拆点, 将每个点拆成\(k+1\)个点, 第i个节点\((u,i)\)表示从起点到\(u\)恰好使用了\(i\)次免费机会, 对于原图中的边\((u,v)\)除了原本的边\(u\rightarrow v\)外, 还需建边\((u,i)\rightarrow (v,i)\)和\((u,i)\rightarrow (v,i+1)\), 表示使用了一次免费机会, 最后求最短路就是答案.
Code
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#define N 1000005
using namespace std;
int n,m,k,nn;
int s,t;
struct Edge{
int v,c,nxt;
}e[N*5];
int head[N],tot;
void AddEdge(int u,int v,int c){
int uu=u*(k+1),vv=v*(k+1);
for(int i=0;i<=k;++i){
e[++tot]=(Edge){vv+i,c,head[uu+i]};head[uu+i]=tot;
e[++tot]=(Edge){uu+i,c,head[vv+i]};head[vv+i]=tot;
}
for(int i=0;i<k;++i){
e[++tot]=(Edge){vv+i+1,0,head[uu+i]};head[uu+i]=tot;
e[++tot]=(Edge){uu+i+1,0,head[vv+i]};head[vv+i]=tot;
}
}
int dis[N];
int vis[N];
queue<int>que;
void spfa(int s){
memset(dis,0x3f,sizeof(dis));
int ss=s*(k+1);
for(int i=0;i<=k;++i){
dis[ss+i]=0;
vis[ss+i]=true;
que.push(ss+i);
}
while(!que.empty()){
int t=que.front();que.pop();
vis[t]=false;
for(int i=head[t];i;i=e[i].nxt){
if(dis[e[i].v]>dis[t]+e[i].c){
dis[e[i].v]=dis[t]+e[i].c;
if(!vis[e[i].v]){
que.push(e[i].v);
vis[e[i].v]=true;
}
}
}
}
// for(int i=0;i<nn;++i)
// cout<<dis[i]<<' ';
// cout<<endl;
}
int main(){
// freopen("a.in","r",stdin);
// freopen("a.out","w",stdout);
scanf("%d%d%d",&n,&m,&k);
nn=n*(k+1);
scanf("%d%d",&s,&t);
for(int i=1;i<=m;++i){
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
AddEdge(a,b,c);
}
spfa(s);
printf("%d\n",dis[t*(k+1)+k]);
return 0;
}
为什么要过别人为我安排的生活.