洛谷 P3034 Cow Photography G/S——题解
洛谷P3034题解
摸鱼环节
[USACO11DEC] Cow Photography G/S
题面翻译
题目描述
今天的奶牛们特别调皮!Farmer John 想做的只是给排成一排的奶牛拍照,但是在他拍下照片之前,奶牛们一直在移动。
具体地说,FJ 有
他按照这样的顺序将奶牛们排列好,但在他按下快门之前,有些奶牛(可能是零头或任意多头奶牛,位置也不一定连续)将移到一个新的位置。更准确地说,一些奶牛离开队列,剩下的奶牛靠拢,这些离开的奶牛再将自己重新插入到队列中的任意位置(不一定是他们之前的位置)。FJ 感到非常沮丧,他再次按照
就这样,FJ 拍了五张照片。给出每张照片拍摄的内容(即 FJ 按下快门时奶牛的顺序),请你尝试推算出 FJ 最初为奶牛们排的顺序(即
输入格式
第一行包含一个整数
接下来
输出格式
输出
样例解释
FJ 拍的五张照片分别为:
10 20 30 40 50
20 10 30 40 50
30 10 20 40 50
40 10 20 30 50
50 10 20 30 40
题目描述
The cows are in a particularly mischievous mood today! All Farmer John wants to do is take a photograph of the cows standing in a line, but they keep moving right before he has a chance to snap the picture.
Specifically, each of FJ's N (1 <= N <= 20,000) cows has a unique integer ID number. FJ wants to take a picture of the cows standing in a line in a very specific ordering, represented by the contents of an array A[1...N], where A[j] gives the ID number of the jth cow in the ordering. He arranges the cows in this order, but just before he can press the button on his camera to snap the picture, a group of zero or more cows (not necessarily a contiguous group) moves to a set of new positions in the lineup. More precisely, a group of zero or more cows steps away from the line, with the remaining cows shifting over to close the resulting gaps in the lineup. The cows who stepped away then re-insert themselves at different positions in the lineup (not necessarily at the locations they originally occupied). Frustrated but not deterred, FJ again arranges his cows according to the ordering in A, but again, right before he can snap a picture, a different group of zero or more cows moves to a set of new positions in the lineup.
The process above repeats for a total of five photographs before FJ gives up. Given the contents of each photograph, see if you can reconstruct the original intended ordering A. Each photograph shows an ordering of the cows that differs from A in that some group of zero or more cows has moved. However, a cow only moves in at most one photograph: if a cow is part of the group that moves in one photograph, she will not actively move in any of the other four photographs (although she could end up at a different index as a consequence of other cows around her moving, of course).
Farmer John居然拍了五张照片,每张表示初始化牛位置的移动后的状态。然后求出FJ这五头牛初始化的样子。
输入格式
* Line 1: The number of cows, N (1 <= N <= 20,000).
* Lines 2..5N+1: The next 5N lines describe five orderings, each one a block of N contiguous lines. Each line contains the ID of a cow, an integer in the range 0...1,000,000,000.
输出格式
* Lines 1..N: The intended ordering A, one ID per line.
样例 #1
样例输入 #1
5
10
20
30
40
50
20
10
30
40
50
30
10
20
40
50
40
10
20
30
50
50
10
20
30
40
样例输出 #1
10
20
30
40
50
提示
There are 5 cows, with IDs 10, 20, 30, 40, and 50. In each of the 5 photos, a different cow moves to the front of the line (at most one cow moves in each photo here, but it is possible in other inputs that multiple cows could move in a particular photo).
The correct original ordering A[1..5] is 10, 20, 30, 40, 50.
又是经典的题面,john与cow的爱情故事john与cow的oi故事,也不知道为啥要给奶牛拍照,咱也不敢问,问了john发力给黑题就完了。于是为了祭拜膜拜john这位oi鼻祖,咱就来写个蓝题。
正片开始
1.草率代码
仔细分析样例可以知道,对于5张照片,只要有奶牛
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=5e6+1;
int n,a[N];
map<int,ll>m[10];//照片编号,奶牛编号——>位置编号
int cmp(int x,int y)
{
int ans=0;//统计次数
for(int i=1;i<=5;i++)//遍历每张照片中x,y的大小关系。
if(m[i][x]<m[i][y]) ans++;
return ans>=3;
}
int main()
{
cin>>n;
for(int i=1;i<=5;i++)
{
for(int j=1;j<=n;j++)
{
int x;cin>>x;
a[j]=x;//每张照片中的元素不变,直接覆盖即可
m[i][x]=j;//用map映射关系
}
}
sort(a+1,a+n+1,cmp);
for(int i=1;i<=n;i++) cout<<a[i]<<endl;
return 0;
}
2.懵逼部分
- 浅浅分析下复杂度,排序自带
,基于map内用红黑树实现,每次查询 ,总复杂就是 ,将小 带入浅算一下,诶嘛直接炸了(但不知道为啥我居然没祭,难不成是数据太水了是我RP值太高了?)。优化算法,很明显用哈希,这里可以用unordered_map
,内部基于哈希实现,体验 查询的快感。 - 实测了一下,最后一个大数据,用原始版map跑了
,用上unordered_map
的话只需要 ,大大提升了代码的B格容错率。
完整代码
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int N=5e6+1;
int n,a[N];
unordered_map<int,ll>m[10];//照片编号,奶牛编号——>位置编号
int cmp(int x,int y)
{
int ans=0;
for(int i=1;i<=5;i++)
if(m[i][x]<m[i][y]) ans++;
return ans>=3;
}
int main()
{
cin>>n;
for(int i=1;i<=5;i++)
{
for(int j=1;j<=n;j++)
{
int x;cin>>x;
a[j]=x;
m[i][x]=j;
}
}
sort(a+1,a+n+1,cmp);
for(int i=1;i<=n;i++) cout<<a[i]<<endl;
return 0;
}
完结收工!!!!!
看完点赞,养成习惯
【推荐】国内首个AI IDE,深度理解中文开发场景,立即下载体验Trae
【推荐】编程新体验,更懂你的AI,立即体验豆包MarsCode编程助手
【推荐】抖音旗下AI助手豆包,你的智能百科全书,全免费不限次数
【推荐】轻量又高性能的 SSH 工具 IShell:AI 加持,快人一步
· 地球OL攻略 —— 某应届生求职总结
· 周边上新:园子的第一款马克杯温暖上架
· Open-Sora 2.0 重磅开源!
· 提示词工程——AI应用必不可少的技术
· .NET周刊【3月第1期 2025-03-02】