HDU2896(AC自动机入门题)

病毒侵袭
Time Limit:1000MS     Memory Limit:32768KB  

Description

当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋――我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~ 
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。 
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~ 
 

Input

第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。 
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20―200之间。 
每个病毒都有一个编号,依此为1―N。 
不同编号的病毒特征码不会相同。 
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。 
接下来M行,每行表示一个网站源码,源码字符串长度在7000―10000之间。 
每个网站都有一个编号,依此为1―M。 
以上字符串中字符都是ASCII码可见字符(不包括回车)。 
 

Output

依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。 
web 网站编号: 病毒编号 病毒编号 … 
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。 
最后一行输出统计信息,如下格式 
total: 带病毒网站数 
冒号后有一个空格。 
 

Sample Input

3
aaa
bbb
ccc
2
aaabbbccc
bbaacc
 

Sample Output

web 1: 1 2 3
total: 1
复制代码
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
const int MAXN=2000005;
const int N=128;
int res;
struct Trie{
    int next[MAXN][N],fail[MAXN],end[MAXN];
    int root;
    int tot,id;
    int newnode()
    {
        for(int i=0;i<N;i++)
            next[tot][i]=-1;
        end[tot++]=0;
        return tot-1;
    }
    
    void init()
    {
        tot=0;
        id=1;
        root=newnode();
    }
    
    void insert(char buf[])
    {
        int len=strlen(buf);
        int now=root;
        for(int i=0;i<len;i++)
        {
            int k=buf[i];
            if(next[now][k]==-1)
                next[now][k]=newnode();
            now=next[now][k];
        }
        end[now]=id++;
    }
    
    void build()
    {
        queue<int> que;
        fail[root]=root;
        for(int i=0;i<N;i++)
            if(next[root][i]==-1)
                next[root][i]=root;
            else
            {
                fail[next[root][i]]=root;
                que.push(next[root][i]);
            }
        
        while(!que.empty())
        {
            int now=que.front();
            que.pop();
            
            for(int i=0;i<N;i++)
                if(next[now][i]==-1)
                    next[now][i]=next[fail[now]][i];
                else
                {
                    fail[next[now][i]]=next[fail[now]][i];
                    que.push(next[now][i]);
                }
        }
    }
    
    void query(char buf[],int t)
    {
        int len=strlen(buf);
        int num[1005],cnt=0;
        int now=root;
        for(int i=0;i<len;i++)
        {
            now=next[now][buf[i]];
            int temp=now;
            while(temp!=root)
            {
                if(end[temp]!=0)
                    num[cnt++]=end[temp];
                //end[temp]=0; 有多个主串参与匹配
                temp=fail[temp];
            }
        }
        if(cnt==0)    return ;
        sort(num,num+cnt);
        cnt=unique(num,num+cnt)-num;//去重
        printf("web %d:",t);
        for(int i=0;i<cnt;i++)
            printf(" %d",num[i]);
        printf("\n");
        res++;
    }
};
int n,m;
Trie ac;
char buf[10005];
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        res=0;
        ac.init();
        for(int i=0;i<n;i++)
        {
            scanf("%s",buf);
            ac.insert(buf);
        }
        ac.build();
        scanf("%d",&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%s",buf);
            ac.query(buf,i);
        }
        printf("total: %d\n",res);
    }
    
    return 0;
}
复制代码

 

 
 

posted on   vCoders  阅读(354)  评论(0编辑  收藏  举报

< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

点击右上角即可分享
微信分享提示