POJ3660(foyld闭包问题)

Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8794   Accepted: 4948

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

题意:给出N个奶牛,M个比赛结果,问最终有几个奶牛可以确定排名。
思路:将N个奶牛视作N个结点,若奶牛a战胜奶牛b,则结点a到结点b有一个有向路径,若奶牛c的排名可以确定,那么能到达结点c的结点个数与c能到达的结点个数之和为n-1
/*
    Accepted    420K        32Ms    

*/ 
#include"cstdio"
using namespace std;
const int MAXN=105;
int mp[MAXN][MAXN];
int N,M;
int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(int i=1;i<=N;i++)
            for(int j=1;j<=N;j++)
                if(i==j)    mp[i][j]=1;
                else mp[i][j]=0;
        for(int i=0;i<M;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            mp[u][v]=1;
        }
        
        for(int k=1;k<=N;k++)
            for(int i=1;i<=N;i++)
                for(int j=1;j<=N;j++)
                    if(mp[i][k]==1&&mp[k][j]==1)
                        mp[i][j]=1;
        
        int ans=0;
        
        for(int i=1;i<=N;i++)
        {
            int num=0;
            for(int j=1;j<=N;j++)
                if(mp[i][j]==1)    num++;
                
            for(int j=1;j<=N;j++)
                if(mp[j][i]==1)    num++;
            
            if(num-2==N-1)    ans++;
        }
        
        printf("%d\n",ans);    
    }    
    return 0;
}

 

posted on 2016-01-22 10:06  vCoders  阅读(191)  评论(0编辑  收藏  举报

导航