POJ2253(djkstra求最长最短边)

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32257   Accepted: 10396

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:求结点1到结点2所有每条路径最长的边中的最短的边。
复制代码
#include"cstdio"
#include"cmath"
using namespace std;
double Max(double x,double y)
{
    if(x>y)    return x;
    else return y;
}
const int MAXN=1002;
const int INF=0x3fffffff;
struct Node{
    int x,y,index;
}a[MAXN];
double mp[MAXN][MAXN];
double distance(int i,int j)
{
    return sqrt((a[i].x-a[j].x)*(a[i].x-a[j].x)+(a[i].y-a[j].y)*(a[i].y-a[j].y));
}
int main()
{
    int cas=1;
    int n;
    while(scanf("%d",&n)!=EOF&&n)
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].index=i+1;
        }
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                mp[a[i].index][a[j].index]=distance(i,j);
            }    
        }
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
                for(int j=1;j<=n;j++)
                    if(mp[k][j]<mp[i][j]&&mp[i][k]<mp[i][j])
                    {
                        mp[i][j]=Max(mp[k][j],mp[k][i]);//mp[i][j]存放i->j路径中的最长边 
                    }
        
        printf("Scenario #%d\n",cas++);
        printf("Frog Distance = %0.3f\n",mp[1][2]);
        printf("\n");
    }
    return 0;
}
复制代码

 dijkstra:

复制代码
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN=1005;
const int INF=0x3f3f3f3f;
struct Node{
    int x,y;
}stone[MAXN];
int n;
double mp[MAXN][MAXN];
double dist(int x1,int y1,int x2,int y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
double d[MAXN];
int vis[MAXN];
double dijkstra(int s)
{
    for(int i=1;i<=n;i++)
    {
        d[i]=mp[s][i];
        vis[i]=0;
    }
    int t=n;
    while(t--)
    {
        double mincost=INF;
        int k;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&mincost>d[i])
            {
                mincost=d[i];
                k=i;
            }    
        }
        vis[k]=1;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&d[i]>max(d[k],mp[k][i]))
            {
                d[i]=max(d[k],mp[k][i]);
            }    
        }
    }
    return d[2];
}
int main()
{
    int t=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                if(i==j)    mp[i][j]=0;
                else    mp[i][j]=INF;
        
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&stone[i].x,&stone[i].y);
        }    
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                double d=dist(stone[i].x,stone[i].y,stone[j].x,stone[j].y);
                mp[i][j]=mp[j][i]=d;
            }
        }
    
        printf("Scenario #%d\n",++t);
        printf("Frog Distance = %.3f\n\n",dijkstra(1));//.lf会WA
    }
    return 0;
}
复制代码

 

posted on   vCoders  阅读(189)  评论(0编辑  收藏  举报

编辑推荐:
· dotnet 源代码生成器分析器入门
· ASP.NET Core 模型验证消息的本地化新姿势
· 对象命名为何需要避免'-er'和'-or'后缀
· SQL Server如何跟踪自动统计信息更新?
· AI与.NET技术实操系列:使用Catalyst进行自然语言处理
阅读排行:
· dotnet 源代码生成器分析器入门
· 官方的 MCP C# SDK:csharp-sdk
· 一款 .NET 开源、功能强大的远程连接管理工具,支持 RDP、VNC、SSH 等多种主流协议!
· 一文搞懂MCP协议与Function Call的区别
· 一次Java后端服务间歇性响应慢的问题排查记录
< 2025年3月 >
23 24 25 26 27 28 1
2 3 4 5 6 7 8
9 10 11 12 13 14 15
16 17 18 19 20 21 22
23 24 25 26 27 28 29
30 31 1 2 3 4 5

导航

统计

点击右上角即可分享
微信分享提示