POJ3067(树状数组:统计数字出现个数)

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24151   Accepted: 6535

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5
题意:两列数字连线,统计线段交叉的产生的点数(交于同一个数字的不算)。两线段相交等价于两端点的值一大一小,一小一大。
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=1000005;
struct Node{
    int east,west;
}road[MAXN];
int k;
int bit[MAXN];
bool comp(Node no1,Node no2)
{
    if(no1.east!=no2.east)
    {
        return no1.east < no2.east;
    }    
    else
    {
        return no1.west < no2.west;
    }
}
void add(int i,int x)
{
    while(i<MAXN)
    {
        bit[i]+=x;
        i+=(i&-i);
    }
}
int sum(int i)
{
    int s=0;
    while(i>0)
    {
        s+=bit[i];
        i-=(i&-i);
    }
    return s;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        memset(bit,0,sizeof(bit));
        scanf("%*d%*d%d",&k);
        for(int i=0;i<k;i++)
        {
            scanf("%d",&road[i].east);
            scanf("%d",&road[i].west);
        }
        sort(road,road+k,comp);
        long long res=0;
        for(int i=k-1;i>=0;i--)
        {
            res+=sum(road[i].west-1);//注意-1,交于同一点不计crossing 
            add(road[i].west,1);
        }
        printf("Test case %d: %lld\n",cas,res);
    }
    
    return 0;
}

 

posted on 2016-01-18 21:18  vCoders  阅读(323)  评论(0编辑  收藏  举报

导航