HDOJ1024(最大M子段和)

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25253    Accepted Submission(s): 8703


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

 

Output
Output the maximal summation described above in one line.
 

 

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
 

 

Sample Output
6
8
#include <cstdio>
#include <cstring>
#define Max(a,b) ((a>b)?(a):(b))
using namespace std;
const int MAXN=1000005;
const int INF=0x3f3f3f3f;
int dp[MAXN],pre[MAXN],a[MAXN];
int m,n;
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        memset(pre,0,sizeof(pre));
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);        
        }
        int mx;
        for(int i=1;i<=m;i++)
        {
            mx=-INF;
            for(int j=i;j<=n;j++)
            {
                dp[j]=Max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=Max(dp[j],mx);
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}

 

posted on 2015-07-31 18:42  vCoders  阅读(180)  评论(0编辑  收藏  举报

导航