HDOJ1016(标准dfs)

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42688    Accepted Submission(s): 18919


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6
8
 

 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
 
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
 
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN=25;
int n,buf[MAXN],vis[MAXN];
bool isPrime(int x)
{
    if(x<=1)    return false;
    for(int i=2;i*i<=x;i++)
    {
        if(x%i==0)    return false;
    }
    return true;
}
void dfs(int dep)
{
    if(dep==n)
    {
        for(int i=0;i<dep-1;i++)
        {
            printf("%d ",buf[i]);
        }
        printf("%d\n",buf[dep-1]);
        return ;
    }
    for(int i=2;i<=n;i++)
    {
        if(!vis[i]&&isPrime(i+buf[dep-1]))
        {
            if(dep==n-1&&!isPrime(i+buf[0]))
                continue;
            vis[i]=1;
            buf[dep]=i;
            dfs(dep+1);
            vis[i]=0;
        }
    }
}
int main()
{
    int cas=0;
    while(scanf("%d",&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        printf("Case %d:\n",++cas);
        buf[0]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}

 

posted on 2015-07-27 17:45  vCoders  阅读(158)  评论(0编辑  收藏  举报

导航