2017 beijing icpc A - Euler theorem

2017-09-22 21:59:43

writer:pprp

HazelFan is given two positive integers a,ba,b, and he wants to calculate amodbamodb. But now he forgets the value of bb and only remember the value of aa, please tell him the number of different possible results.

InputThe first line contains a positive integer T(1T5)T(1≤T≤5), denoting the number of test cases. 
For each test case: 
A single line contains a positive integer a(1a109)a(1≤a≤109).
OutputFor each test case: 

A single line contains a nonnegative integer, denoting the answer. 

Sample Input

2
1
3

Sample Output

2
3
复制代码
#include<iostream>
#include<string.h>
#include<stdlib.h>

using namespace std;

int main()
{
    int i,n;
    cin>>n;
    for(i = 0;i<n;++i)
    {
        int x;
        cin>>x;
        if(x%2==0)
        {
            cout<<(x/2)+1<<endl;
        }
        else if(x%2 == 1)
        {
            x++;
            cout<<(x/2)+1<<endl;
        }
    }
    return 0;
}
复制代码

 

posted @   pprp  阅读(165)  评论(0编辑  收藏  举报
编辑推荐:
· Linux glibc自带哈希表的用例及性能测试
· 深入理解 Mybatis 分库分表执行原理
· 如何打造一个高并发系统?
· .NET Core GC压缩(compact_phase)底层原理浅谈
· 现代计算机视觉入门之:什么是图片特征编码
阅读排行:
· 手把手教你在本地部署DeepSeek R1,搭建web-ui ,建议收藏!
· Spring AI + Ollama 实现 deepseek-r1 的API服务和调用
· 数据库服务器 SQL Server 版本升级公告
· 程序员常用高效实用工具推荐,办公效率提升利器!
· C#/.NET/.NET Core技术前沿周刊 | 第 23 期(2025年1.20-1.26)
点击右上角即可分享
微信分享提示