poj1028--动态规划--Ignatius and the Princess III

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16122    Accepted Submission(s): 11371


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 
/*#include<stdio.h>
#include<string.h>
int dp[1000][1000],n;
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		for(int i=1;i<1000;i++)
		dp[i][1]=dp[1][i]=1;
		for(int i=2;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(i>j) dp[i][j]=dp[i-j][j]+dp[i][j-1];
				else if(i==j) dp[i][j]=dp[i][j-1]+1;
				else dp[i][j]=dp[i][i];
			}
		}
		printf("%d\n",dp[n][n]);
	}
	return 0;
}*/
#include<stdio.h>
#include<string.h>
int dp[1200];
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(int i=1;i<=n;i++)
		for(int j=i;j<=n;j++)
		{
			dp[j]+=dp[j-i];
		}
		printf("%d\n",dp[n]);
	}
}


posted @ 2015-10-11 17:38  上弦月307  阅读(157)  评论(0编辑  收藏  举报