hdoj--3123--GCC(技巧阶乘取余)

GCC

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4473    Accepted Submission(s): 1472



Problem Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means "the product of the integers from 1 to n". For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + ... + n!)%m
 

Input
The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.
 

Output
Output the answer of (0! + 1! + 2! + 3! + 4! + ... + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000
 

Sample Input
1 10 861017
 

Sample Output
593846
 

Source
2009 Asia Wuhan Regional Contest Online

好吧,0!是1,我服了,,,,,

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define ll long long
#define N 1000010
using namespace std;
char s[110];
ll sum[N];
ll change(char *s)
{
	int l,i,ans=0;
	l=strlen(s);
	for(i=0;i<l;i++)
		ans=ans*10+(s[i]-'0');
	return ans; 
}
int main()
{
	int t;
	int n,m;
	int i,j,k,l;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s%d",s,&m);
		l=strlen(s);
		if(l<7)
		{
			n=change(s);
			if(n>m)
				n=m-1;
			sum[0]=1;
			int ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%d\n",(ans+1)%m);
		}
		else
		{
			n=m-1;
			sum[0]=1;
			int ans=0;
			for(i=1;i<=n;i++)
			{
				sum[i]=(sum[i-1]*i)%m;
				ans=(ans+sum[i])%m;
			}
			printf("%d\n",(ans+1)%m);
		}
	}
	return 0;
}


posted @ 2015-12-10 21:25  上弦月307  阅读(269)  评论(0编辑  收藏  举报