lightoj--1214--Large Division(大数取余)

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %lld & %llu

Submit Status

Description

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

Source

Problem Setter: Jane Alam Jan

水题一枚


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s[1001];
int main()
{
	int t,k=1;
	scanf("%d",&t);
	while(t--)
	{
		memset(s,'\0',sizeof(s));
		scanf("%s",s);
		long long mod,temp;
		scanf("%lld",&mod);
		temp=0;
		for(int i=0;i<strlen(s);i++)
		{
			if(s[i]=='-') continue;
			temp=temp*10+(s[i]-'0');
			temp%=mod;
		}
		if(temp%mod)
		printf("Case %d: not divisible\n",k++);
		else
		printf("Case %d: divisible\n",k++);
	}
	return 0;
}


posted @ 2015-12-14 08:57  上弦月307  阅读(225)  评论(0编辑  收藏  举报