zoj--3870--Team Formation(位运算好题)

Time Limit: 3000MS   Memory Limit: 131072KB   64bit IO Format: %lld & %llu

Status

Description

For an upcoming programming contest, Edward, the headmaster of Marjar University, is forming a two-man team from N students of his university.

Edward knows the skill level of each student. He has found that if two students with skill level A and B form a team, the skill level of the team will be AB, where ⊕ means bitwise exclusive or. A team will play well if and only if the skill level of the team is greater than the skill level of each team member (i.e. AB > max{A, B}).

Edward wants to form a team that will play well in the contest. Please tell him the possible number of such teams. Two teams are considered different if there is at least one different team member.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (2 <= N <= 100000), which indicates the number of student. The next line contains N positive integers separated by spaces. The ith integer denotes the skill level of ith student. Every integer will not exceed 109.

Output

For each case, print the answer in one line.

Sample Input

2
3
1 2 3
5
1 2 3 4 5

Sample Output

1
6

Hint

Source

The 12th Zhejiang Provincial Collegiate Programming Contest
神奇的位运算

#include<cstdio>
#include<cstring>
int a[100100];
int num[40];
void sum(int x)
{
	int pos=31;
	while(pos>=0)
	{//1左移31位,&同为1时为1,其他为0 
		if(x&(1<<pos))//寻找最高的二进制位 
		{
			num[pos]++;
			return ;
		}
		pos--;
	}
}
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(num,0,sizeof(num));
		for(int i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
			sum(a[i]);
		}
		long long ans=0;
		for(int i=0;i<n;i++)
		{
			int pos=31;
			while(pos)
			{
				if(a[i]&(1<<pos))
				break;
				pos--;
			}
			while(pos>=0)
			{
				if(!(a[i]&(1<<pos)))
				ans+=num[pos];//num中存储的最高位为pos的数的个数 
				pos--;
			}
		}
		printf("%lld\n",ans);
	}
	return 0;
}


posted @ 2016-03-01 21:43  上弦月307  阅读(203)  评论(0编辑  收藏  举报