POJ 1182 食物链

食物链
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 53679   Accepted: 15738

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。 
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。 
有人用两种说法对这N个动物所构成的食物链关系进行描述: 
第一种说法是"1 X Y",表示X和Y是同类。 
第二种说法是"2 X Y",表示X吃Y。 
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。 
1) 当前的话与前面的某些真的话冲突,就是假话; 
2) 当前的话中X或Y比N大,就是假话; 
3) 当前的话表示X吃X,就是假话。 
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。 

Input

第一行是两个整数N和K,以一个空格分隔。 
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。 
若D=1,则表示X和Y是同类。 
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

并查集 考虑到3种情况 0 1 2分别代表c b a 即1吃0 2吃1 0吃2

/* ***********************************************
Author        :pk28
Created Time  :2015/8/16 16:28:41
File Name     :4.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 50000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;

bool cmp(int a,int b){
    return a>b;
}
int n,k,ans;
int fa[maxn],d[maxn];
void init(){
    for(int i=1;i<=n;i++){
        d[i]=0;
        fa[i]=i;
    }
    ans=0;
}
int findfa(int x){
    if(x==fa[x])return x;
    else{
        int root=findfa(fa[x]);
        d[x]=(d[x]+d[fa[x]])%3;
        fa[x]=root;
        return fa[x];
    }
}
void Union(int a,int b,int t){
    int x=findfa(a);
    int y=findfa(b);
    if(x==y){
        if(t==1&&(d[a]!=d[b]))ans++;
        if(t==2){
            if(d[a]==2&&d[b]!=1)ans++;
            if(d[a]==1&&d[b]!=0)ans++;
            if(d[a]==0&&d[b]!=2)ans++;
        }
        return ;
    }
    fa[x]=y;
    if(t==1) d[x]=(d[b]-d[a]+3)%3;
    else d[x]=(d[b]-d[a]+1+3)%3;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int t,a,b;
    cin>>n>>k;
        init();
        for(int i=1;i<=k;i++){
            scanf("%d %d %d",&t,&a,&b);
            if(a>n||b>n||(t==2&&a==b)){ans++;continue;}
            Union(a,b,t);
        }
        printf("%d\n",ans);
    
    return 0;
}

 

 

posted on 2015-08-17 00:03  Beserious  阅读(186)  评论(0编辑  收藏  举报