HDU1548 A strange lift

Problem Description

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?

Input

The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.
A single 0 indicate the end of the input.

Output

For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.

Sample Input
5 1 5
3 3 1 2 5
0

Sample Output
3

思路

每层电梯都有一个数字ki,电梯上有两个按钮上和下.

按下 上会到达当前层+当前层上的数字,也就是i+ki。

按下 下会到达当前层-当前层上的数字,也就是i-ki。

求从A到B按的次数最少是多少。

也就是每次有两种可能,然后判断每一种可能性。

队列中每个层去搜索可到达的层,层数不满足提议,重新找,然后判断可达到的层是否是终点,是终点结束,不是加入队列,将这个层标记为已访问,步数加一。

代码

#include<algorithm>  
#include<cstdio>  
#include<cstring>  
#include<cmath>  
#include<cstdlib>  
#include<iostream>  
#include<queue>  
using namespace std;  
int visit[205];
int step[205];  
int head;
int N, A, B;
int k[205];    
int now;
int bfs()
{
    queue<int> lift;
    lift.push(A);//把A这个节点的放入队列
    visit[A] = 1;
    step[A] = 0;

        while(!lift.empty())
        {    
            //int j = 1;
            head = lift.front();
            lift.pop();
            for(int l = 0; l < 2; l++)
            {    
                if(l == 0)
                    now = head+ k[head];
                else
                    now =head- k[head];

                if(now < 1 || now > N)
                    continue;
                if(!visit[now])
                {
                    lift.push(now);
                    visit[now] = 1;
                    step[now] = step[head]+1;
                }
                if(now == B)
                {
                    return step[now];
                }
            }        
        }

    return -1;
}
int main()
{


    while(scanf("%d",&N)!=EOF)  
    {
         memset(visit,0,sizeof(visit));
        memset(step,0,sizeof(step));  

        if(N== 0)
            break;
        scanf("%d%d",&A,&B);
    for(int i = 1; i <= N; i++)
        scanf("%d",&k[i]);
          printf("%d\n",bfs());  

    }
    return 0;
}
posted @ 2017-08-28 22:15  云胡同学  阅读(160)  评论(0编辑  收藏  举报