C语言合法标识符

http://acm.hdu.edu.cn/showproblem.php?pid=2024

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12090    Accepted Submission(s): 5078


Problem Description
输入一个字符串,判断其是否是C的合法标识符。
 

Input
输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。
 

Output
对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。
 

Sample Input
3 12ajf fi8x_a ff ai_2
 

Sample Output
no yes no
 
 
x
#include<stdio.h>
int main()
{
	int n,i,sum;
	char s[200];
	scanf("%d",&n);
	getchar();
	while(n--)
	{
		gets(s);
		sum=0;
		for(i=0;s[i]!='\0';i++)
		{
			if(s[i]<0)
			{
				sum++;
				i++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}
posted on 2011-05-13 20:27  pcoda  阅读(509)  评论(0编辑  收藏  举报