http://acm.hdu.edu.cn/showproblem.php?pid=1005


Number Sequence
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37400    Accepted Submission(s): 7879


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0
 

Sample Output
2
5

#include <stdio.h>
int main()
{
    int a,b;
    long n;
    int f[201];
    int i;
    while(scanf("%d%d%ld",&a,&b,&n)!=EOF)
    {
        if(n==0&&a==0&&b==0)
            break;
        f[1]=1;
        f[2]=1;
        if (n>=3)
        {
            for(i=3;i<200;i++)
            {
                f[i]=(a*f[i-1]+b*f[i-2])%7;
                if ((f[i-1]==1)&&(f[i]==1))
                {
                    break;
                }
            }
            i=i-2;
            n%=i;
            if (n==0)
            {
                n=i;
            }
            printf("%d\n",f[n]);
        }
        else
        {
            printf("1\n");
        }
    }
    return 0;
}
posted on 2011-04-26 21:04  pcoda  阅读(842)  评论(1编辑  收藏  举报