http://acm.hdu.edu.cn/showproblem.php?pid=1003

Max Sum
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49213    Accepted Submission(s): 10950


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1:
14 1 4

Case 2:

#include <iostream>
using namespace std;
int main()
{
	int T,N,num,startP,endP;
	cin>>T;
	for(int k=0;k<T;k++)
	{
		cin>>N;
		int max=-1001,sum=0,temp=1;
		for(int i=0;i<N;i++)
		{
			cin>>num;
			sum+=num;
			if(sum>max)
			{
				max=sum;
				startP=temp;
				endP=i+1;
			}
			if(sum<0)
			{
				sum=0;
				temp=i+2;
			}
		}
		cout<<"Case "<<k+1<<":"<<endl<<max<<" "<<startP<<" "<<endP<<endl;
		if(k!=T-1) cout<<endl;
	}
	return 0;
}


#include<stdio.h>
int main()
{
	int T,N,i,j,startP,endP,max,num,sum,temp;
	scanf("%d",&T);
	for(j=0;j<T;j++)
	{
		max=-1001;
		temp=1;sum=0;
		scanf("%d",&N);
		for(i=0;i<N;i++)
		{
			scanf("%d",&num);
			sum+=num;
			if(sum>max)
			{
				max=sum;
				startP=temp;
				endP=i+1;
			}
			if(sum<0)
			{
				sum=0;
				temp=i+2;
			}
		}
		printf("Case %d:\n%d %d %d\n",j+1,max,startP,endP);
		if(j<T-1)
			printf("\n");
	}
	return 0;
}


7 1 6



posted on 2011-04-25 22:08  pcoda  阅读(911)  评论(0编辑  收藏  举报