BZOJ 1012: [JSOI2008]最大数maxnumber
BZOJ 1012: [JSOI2008]最大数maxnumber
Description
现在请求你维护一个数列,要求提供以下两种操作:1、 查询操作。语法:Q L 功能:查询当前数列中末尾L
个数中的最大的数,并输出这个数的值。限制:L不超过当前数列的长度。2、 插入操作。语法:A n 功能:将n加
上t,其中t是最近一次查询操作的答案(如果还未执行过查询操作,则t=0),并将所得结果对一个固定的常数D取
模,将所得答案插入到数列的末尾。限制:n是非负整数并且在长整范围内。注意:初始时数列是空的,没有一个
数。
Input
第一行两个整数,M和D,其中M表示操作的个数(M <= 200,000),D如上文中所述,满足D在longint内。接下来
M行,查询操作或者插入操作。
Output
对于每一个询问操作,输出一行。该行只有一个数,即序列中最后L个数的最大数。
Sample Input
5 100
A 96
Q 1
A 97
Q 1
Q 2
Sample Output
96
93
96
HINT
数据如下http://pan.baidu.com/s/1i4JxCH3
Source
Solution
修改操作显然有单调性,用单调栈维护,二分查找即可。
Code
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
#define fo(i,a,b) for(int i=a;i<=b;i++)
#define fd(i,a,b) for(int i=a;i>=b;i--)
#define rep(i,x) for(int i=head[x];i;i=e[i].next)
#define mem(a,x) memset(a,x,sizeof(a))
typedef long long LL;
typedef double DB;
using namespace std;
template <typename T> inline T read(T &a) {
T x=0,f=1;char ch=getchar();
while(ch<'0'||ch>'9') f=(ch=='-')?-1:f,ch=getchar();
while(ch>='0'&&ch<='9') x=x*10+(ch-'0'),ch=getchar();a=f*x;
}
int n,d,t;
int top,len,a[200001],num[200001];
int main() {
int x;
char ch[1];
read(n),read(d);
while(n--) {
scanf("%s",ch),read(x);
if(ch[0]=='A') {
x=(x+t)%d;
num[++len]=x;
while(top&&num[a[top]]<=x) top--;
a[++top]=len;
} else {
int y=lower_bound(a+1,a+top+1,len-x+1)-a;
t=num[a[y]];
printf("%d\n",t=num[a[y]]);
}
}
return 0;
}