poj3252 Round Numbers

Round Numbers
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 7625   Accepted: 2625

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start.. Finish

Sample Input

2 12

Sample Output

6
如果一个数二进制数中的,0比1多或相等,就是目标数,求一定范围的个数!数位dp,可以看出来,数位dp,我们用dp[i][j][k][a]表是第i位已经有j个1,总的位数是k,是否已经出现过0,这样,就可以轻易的用dp,做出来了!
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
#define M 40
int pri[M],dp[M][40][40][2];
int get(int i,int one,int bit){
    if(one==0&&i==0)return bit-1;
    return bit;
}
int dfs(int pos,int bit,int t,int flag,int one){
    if(pos==0)return t<=bit/2;
    if(!flag&&dp[pos][t][bit][one]!=-1)return dp[pos][t][bit][one];
    int u=flag?pri[pos]:1,ans=0;
    for(int i=0;i<=u;i++)
    ans+=dfs(pos-1,get(i,one,bit),t+i,flag&&i==u,one||i);
    return flag?ans:dp[pos][t][bit][one]=ans;
}
int solve(int x){
    int cnt=0;
    while(x){
        pri[++cnt]=x%2;x/=2;
    }
    return dfs(cnt,cnt,0,1,0);
}
int main()
{
    int n,m;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d%d",&n,&m)!=EOF){
        //for(m=100;m>=0;m--)
        printf("%d\n",solve(m)-solve(n-1));
    }
    return 0;
}


posted @ 2013-10-09 18:24  pangbangb  阅读(171)  评论(0编辑  收藏  举报