Wooden Sticks
时间限制(普通/Java):1500MS/15000MS 运行内存限制:65536KByte 总提交: 31 测试通过: 12
描述
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: (a) The setup time for the first wooden stick is 1 minute. (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
输入
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
输出
The output should contain the minimum setup time in minutes, one per line.
样例输入
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
样例输出
2
1
3
题目上传者
crq
|
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
struct info {
int x;
int y;
bool tag;
};
int n;
vector<info> v;
bool cmp(const info& a, const info& b) {
return a.x < b.x;
if(a.x != b.x)
return a.y < b.y;
}
void work() {
int i, j;
int Size = v.size();
int cnt = 0;// store result;
for(i = 0; i < Size; i++) {
if(v[i].tag==false) {
cnt++;
for(j = i+1; j < Size; j++){
if(v[j].x >= v[i].x && v[j].y >= v[i].y && v[j].tag==false){
v[i].x = v[j].x; v[i].y = v[j].y;
v[j].tag = true;
}
}
v[i].tag = true;
}
}
printf("%d\n", cnt);
}
int main()
{
int T, i;
info tmp;
scanf("%d", &T);
while(T--) {
scanf("%d", &n);
v.clear();
for(i = 0; i < n; i++) {
scanf("%d%d", &tmp.x, &tmp.y);
tmp.tag = false;
v.push_back(tmp);
}
sort(v.begin(), v.end(), cmp);
work();
}
return 0;
}