原文链接:https://blog.51cto.com/692344/1075579
https://blog.csdn.net/weixin_34205826/article/details/91530936
R1配置:
vpdn enable
vpdn search-order domain
!
vpdn-group LAC
! Default L2TP VPDN group
request-dialin
protocol l2tp
domain cisco.com
initiate-to ip 12.1.1.2
local name LAC
no l2tp tunnel authentication
!
bba-group pppoe global
virtual-template 1
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
no ip address
half-duplex
pppoe enable group global
!
interface Ethernet0/1
ip address 12.1.1.1 255.255.255.0
half-duplex
!
interface Virtual-Template1
ip unnumbered Loopback0
ip mtu 1492
no peer default ip address
ppp authentication chap
R2配置:
vpdn enable
!
vpdn-group lns
accept-dialin
protocol l2tp
virtual-template 1
terminate-from hostname LAC
local name LNS
no l2tp tunnel authentication
!
username cisco@cisco.com password 0 cisco
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Ethernet0/0
ip address 23.1.1.2 255.255.255.0
half-duplex
!
interface Ethernet0/1
ip address 12.1.1.2 255.255.255.0
half-duplex
!
interface Virtual-Template1
ip unnumbered Loopback0
ip mtu 1492
peer default ip address pool surf
ppp authentication chap
!
ip local pool surf 100.0.0.1 100.0.0.10
R3配置:
vpdn enable
!
interface Ethernet0/0
no ip address
half-duplex
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 1
ppp authentication chap pap callin
ppp chap hostname cisco@cisco.com
ppp chap password 0 cisco
!
ip route 0.0.0.0 0.0.0.0 Dialer0
R4配置:
interface Ethernet0/0
ip address 23.1.1.3 255.255.255.0
half-duplex
!
ip route 0.0.0.0 0.0.0.0 23.1.1.2