2013年12月15日

时间限制: 1 Sec  内存限制: 128 MB
提交: 460  解决: 151
[提交][状态][讨论版]

题目描述

请设计输出实数的格式,包括:⑴一行输出一个实数;⑵一行内输出两个实数;⑶一行内输出三个实数。实数用"6.2f"格式输出。

输入

一个实数,float范围

输出

输出3行,第一行打印一遍输入的数,第二行打印两遍,第三行打印三遍。第二行和第三行,用空格分隔同一行的数字。实数用"6.2f"格式输出。

样例输入

0.618

样例输出

0.62 0.62 0.62 
0.62 0.62 0.62
#includeiostream>
#includecmath>
#includeiomanip>
using namespace std;
int main()
{float n;
cin>>n;
cout<<setw(6)<<fixed<<setprecision(2)<<n<<endl;
cout<<setw(6)<<fixed<<setprecision(2)<<n<<" "<<setw(6)<<fixed<<setprecision(2)<<n<<endl;
cout<<setw(6)<<fixed<<setprecision(2)<<n<<" "<<setw(6)<<fixed<<setprecision(2)<<n<<" "<<setw(6)<<fixed<<setprecision(2)<<n<<endl;
return 0;
}
posted @ 2013-12-22 15:58  IT专业户  阅读(151)  评论(0编辑  收藏  举报