Max Sum

Max Sum

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 52   Accepted Submission(s) : 12

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
    #include<iostream>
using namespace std;
    int a[100005],b[100005],ans,ma;
    int s1,s2,k,m,n,j,i,s,ll,kk,sum;
    int main()
    {
        ll=0;
        
        cin>>k;
        for(s=1;s<=k;s++)
        {
            if(ll!=0)
                cout<<endl;
            else
                ll=1;
            ans=-100000000;
            cin>>n;
            memset(a,0,sizeof(a));
           for(i=1;i<=n;i++)
               scanf("%d",&b[i]);
           a[1]=b[1];
           sum=ma=b[1];
           s1=1;s2=1;kk=1;
           for(i=2;i<=n;i++)
           {
               
               if(ma<sum)
               {ma=sum;s1=kk;s2=i-1;}
               if(sum<0)
               { sum=0;kk=i;}
              sum=sum+b[i];

           }
           if(ma<sum)
               {ma=sum;s1=kk;s2=i-1;}
               cout<<"Case "<<s<<":"<<endl;
               printf("%d",ma);
               cout<<' '<<s1<<' '<<s2<<endl;
               


        }
    
    
         
        return 0;
    }

posted @ 2014-04-19 17:09  IT专业户  阅读(176)  评论(0编辑  收藏  举报