hdu1004----用java链表实现

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60158    Accepted Submission(s): 22125


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red pink
 

Author
WU, Jiazhi
 
import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		while(sc.hasNext()){
			int t=Integer.parseInt(sc.next());
			int a[]=new int[1007];
			if(t==0)
				break;
			LinkedList<String> str=new LinkedList<String>();
			int count=0;
			for(int i=0;i<t;i++){
				String color=sc.next();
				if(str.contains(color)==false){
					str.add(count,color);
					a[count]=1;
					count++;
				 }
				else{
					a[str.indexOf(color)]+=1;
				}
				
			}
			int max=0;
			int n=0;
			for(int i=0;i<t;i++){
			    if(a[i]>max){
				      max=a[i];
				      n=i;
			    }
			}
			System.out.println(str.get(n));
		}

	}

}

posted @ 2013-10-17 22:08  IT专业户  阅读(186)  评论(0编辑  收藏  举报